Re: Java Versions, was; [VOTE] Release Pivot 2.0.5

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Java Versions, was; [VOTE] Release Pivot 2.0.5

Niclas Hedhman
Ok, sorry that I haven't followed exactly what is going where and when. It
was just in the back of my mind...

On Mon, Jul 3, 2017 at 12:02 PM, Roger and Beth Whitcomb <
[hidden email]> wrote:

> The 2.0.x branch still only requires Java 6; this is to maintain backward
> compatibility with 2.0.4, since it is only a bug fix release, basically.
> For "trunk" though (that will be 2.1, probably), we are now requiring Java
> 8...
>
> HTH,
> ~Roger
>
>
> On 7/2/17 4:58 PM, Niclas Hedhman wrote:
>
>> +1 from me.
>>
>> But for future reference, doesn't Pivot require Java 7 or Java 8 already??
>> The manifest says 1.6. Small detail IMHO, but I thought I should mention
>> it.
>>
>> =======================================================================
>> ==./eclipse/META-INF/MANIFEST.MF
>> =======================================================================
>> Manifest-Version: 1.0
>> Bundle-ManifestVersion: 2
>> Bundle-Name: Eclipse Plug-in for Apache Pivot
>> Bundle-SymbolicName: org.apache.pivot.eclipse;singleton:=true
>> Bundle-Version: 2.0
>> Bundle-Vendor: Apache Software Foundation
>> Bundle-RequiredExecutionEnvironment: JavaSE-1.6
>> Require-Bundle: org.eclipse.core.runtime;bundle-version="3.5.0",
>>   org.eclipse.ui;bundle-version="3.5.2",
>>   org.eclipse.swt;bundle-version="3.5.2",
>>   org.eclipse.jface;bundle-version="3.5.2",
>>   org.eclipse.debug.core;bundle-version="3.5.1",
>>   org.eclipse.debug.ui;bundle-version="3.5.2",
>>   org.eclipse.jdt.core;bundle-version="3.5.2",
>>   org.eclipse.jdt.launching;bundle-version="3.5.1",
>>   org.eclipse.jdt.debug.ui;bundle-version="3.4.1"
>>
>>
>>
>> On Mon, Jun 26, 2017 at 6:00 AM, Sandro Martini <[hidden email]
>> >
>> wrote:
>>
>> Hi All,
>>>
>>> the Pivot 2.0.5 release candidate has been tagged, packaged, and is
>>> ready for a vote.
>>> The artifacts, RAT reports, and KEYS file can be found here:
>>> http://people.apache.org/~smartini/pivot-2.0.5_release/
>>>
>>> Note that just for convenience there are even Maven bundles for
>>> installing them in a real Maven Repository:
>>> http://people.apache.org/~smartini/pivot-2.0.5_maven/
>>>
>>>
>>> The tag from which the release artifacts were generated can be found
>>> here:
>>> http://svn.apache.org/repos/asf/pivot/tags/2.0.5/
>>>
>>> In addition, my PGP public code signing key can be found at the MIT
>>> key server (http://pgp.mit.edu/), but just for convenience that key is
>>> even here:
>>> http://people.apache.org/~smartini/F9EDAF10.asc , and
>>> smartini_apache.asc is only a copy of it with a better name.
>>>
>>> Please vote to publish this release by Monday , July 03 at 12:00 GMT.
>>> Note that voting may conclude early if people have the time to look
>>> earlier (but in any case, minimum 72 hours).
>>>
>>> Remember that the Apache Voting Process requires a minimum of 3
>>> Bindings +1 vote for the release to be successful (see the "Votes on
>>> Package Release" paragraph).
>>>
>>> In your vote, please include the testing you performed to arrive at your
>>> vote.
>>>
>>> [  ] +1 Publish
>>> [  ] +0
>>> [  ] -0
>>> [  ] -1 Don't publish
>>>
>>> Thanks,
>>> Sandro
>>>
>>>
>>
>>
>


--
Niclas Hedhman, Software Developer
http://polygene.apache.org - New Energy for Java
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Java Versions, was; [VOTE] Release Pivot 2.0.5

Sandro Martini
Hi Niclas,
don't worry, the important is your test on artifacts and your vote :-) ...

Stay well and thanks for all.

Bye,
Sandro


2017-07-03 6:23 GMT+02:00 Niclas Hedhman <[hidden email]>:

> Ok, sorry that I haven't followed exactly what is going where and when. It
> was just in the back of my mind...
>
> On Mon, Jul 3, 2017 at 12:02 PM, Roger and Beth Whitcomb <
> [hidden email]> wrote:
>
>> The 2.0.x branch still only requires Java 6; this is to maintain backward
>> compatibility with 2.0.4, since it is only a bug fix release, basically.
>> For "trunk" though (that will be 2.1, probably), we are now requiring Java
>> 8...
>>
>> HTH,
>> ~Roger
>>
>>
>> On 7/2/17 4:58 PM, Niclas Hedhman wrote:
>>
>>> +1 from me.
>>>
>>> But for future reference, doesn't Pivot require Java 7 or Java 8 already??
>>> The manifest says 1.6. Small detail IMHO, but I thought I should mention
>>> it.
>>>
>>> =======================================================================
>>> ==./eclipse/META-INF/MANIFEST.MF
>>> =======================================================================
>>> Manifest-Version: 1.0
>>> Bundle-ManifestVersion: 2
>>> Bundle-Name: Eclipse Plug-in for Apache Pivot
>>> Bundle-SymbolicName: org.apache.pivot.eclipse;singleton:=true
>>> Bundle-Version: 2.0
>>> Bundle-Vendor: Apache Software Foundation
>>> Bundle-RequiredExecutionEnvironment: JavaSE-1.6
>>> Require-Bundle: org.eclipse.core.runtime;bundle-version="3.5.0",
>>>   org.eclipse.ui;bundle-version="3.5.2",
>>>   org.eclipse.swt;bundle-version="3.5.2",
>>>   org.eclipse.jface;bundle-version="3.5.2",
>>>   org.eclipse.debug.core;bundle-version="3.5.1",
>>>   org.eclipse.debug.ui;bundle-version="3.5.2",
>>>   org.eclipse.jdt.core;bundle-version="3.5.2",
>>>   org.eclipse.jdt.launching;bundle-version="3.5.1",
>>>   org.eclipse.jdt.debug.ui;bundle-version="3.4.1"
>>>
>>>
>>>
>>> On Mon, Jun 26, 2017 at 6:00 AM, Sandro Martini <[hidden email]
>>> >
>>> wrote:
>>>
>>> Hi All,
>>>>
>>>> the Pivot 2.0.5 release candidate has been tagged, packaged, and is
>>>> ready for a vote.
>>>> The artifacts, RAT reports, and KEYS file can be found here:
>>>> http://people.apache.org/~smartini/pivot-2.0.5_release/
>>>>
>>>> Note that just for convenience there are even Maven bundles for
>>>> installing them in a real Maven Repository:
>>>> http://people.apache.org/~smartini/pivot-2.0.5_maven/
>>>>
>>>>
>>>> The tag from which the release artifacts were generated can be found
>>>> here:
>>>> http://svn.apache.org/repos/asf/pivot/tags/2.0.5/
>>>>
>>>> In addition, my PGP public code signing key can be found at the MIT
>>>> key server (http://pgp.mit.edu/), but just for convenience that key is
>>>> even here:
>>>> http://people.apache.org/~smartini/F9EDAF10.asc , and
>>>> smartini_apache.asc is only a copy of it with a better name.
>>>>
>>>> Please vote to publish this release by Monday , July 03 at 12:00 GMT.
>>>> Note that voting may conclude early if people have the time to look
>>>> earlier (but in any case, minimum 72 hours).
>>>>
>>>> Remember that the Apache Voting Process requires a minimum of 3
>>>> Bindings +1 vote for the release to be successful (see the "Votes on
>>>> Package Release" paragraph).
>>>>
>>>> In your vote, please include the testing you performed to arrive at your
>>>> vote.
>>>>
>>>> [  ] +1 Publish
>>>> [  ] +0
>>>> [  ] -0
>>>> [  ] -1 Don't publish
>>>>
>>>> Thanks,
>>>> Sandro
>>>>
>>>>
>>>
>>>
>>
>
>
> --
> Niclas Hedhman, Software Developer
> http://polygene.apache.org - New Energy for Java
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Java Versions, was; [VOTE] Release Pivot 2.0.5

Roger and Beth Whitcomb
In reply to this post by Niclas Hedhman
Thank you for checking -- that's part of the job ;)

~Roger


On 7/2/17 9:23 PM, Niclas Hedhman wrote:

> Ok, sorry that I haven't followed exactly what is going where and when. It
> was just in the back of my mind...
>
> On Mon, Jul 3, 2017 at 12:02 PM, Roger and Beth Whitcomb <
> [hidden email]> wrote:
>
>> The 2.0.x branch still only requires Java 6; this is to maintain backward
>> compatibility with 2.0.4, since it is only a bug fix release, basically.
>> For "trunk" though (that will be 2.1, probably), we are now requiring Java
>> 8...
>>
>> HTH,
>> ~Roger
>>
>>
>> On 7/2/17 4:58 PM, Niclas Hedhman wrote:
>>
>>> +1 from me.
>>>
>>> But for future reference, doesn't Pivot require Java 7 or Java 8 already??
>>> The manifest says 1.6. Small detail IMHO, but I thought I should mention
>>> it.
>>>
>>> =======================================================================
>>> ==./eclipse/META-INF/MANIFEST.MF
>>> =======================================================================
>>> Manifest-Version: 1.0
>>> Bundle-ManifestVersion: 2
>>> Bundle-Name: Eclipse Plug-in for Apache Pivot
>>> Bundle-SymbolicName: org.apache.pivot.eclipse;singleton:=true
>>> Bundle-Version: 2.0
>>> Bundle-Vendor: Apache Software Foundation
>>> Bundle-RequiredExecutionEnvironment: JavaSE-1.6
>>> Require-Bundle: org.eclipse.core.runtime;bundle-version="3.5.0",
>>>    org.eclipse.ui;bundle-version="3.5.2",
>>>    org.eclipse.swt;bundle-version="3.5.2",
>>>    org.eclipse.jface;bundle-version="3.5.2",
>>>    org.eclipse.debug.core;bundle-version="3.5.1",
>>>    org.eclipse.debug.ui;bundle-version="3.5.2",
>>>    org.eclipse.jdt.core;bundle-version="3.5.2",
>>>    org.eclipse.jdt.launching;bundle-version="3.5.1",
>>>    org.eclipse.jdt.debug.ui;bundle-version="3.4.1"
>>>
>>>
>>>
>>> On Mon, Jun 26, 2017 at 6:00 AM, Sandro Martini <[hidden email]
>>> wrote:
>>>
>>> Hi All,
>>>> the Pivot 2.0.5 release candidate has been tagged, packaged, and is
>>>> ready for a vote.
>>>> The artifacts, RAT reports, and KEYS file can be found here:
>>>> http://people.apache.org/~smartini/pivot-2.0.5_release/
>>>>
>>>> Note that just for convenience there are even Maven bundles for
>>>> installing them in a real Maven Repository:
>>>> http://people.apache.org/~smartini/pivot-2.0.5_maven/
>>>>
>>>>
>>>> The tag from which the release artifacts were generated can be found
>>>> here:
>>>> http://svn.apache.org/repos/asf/pivot/tags/2.0.5/
>>>>
>>>> In addition, my PGP public code signing key can be found at the MIT
>>>> key server (http://pgp.mit.edu/), but just for convenience that key is
>>>> even here:
>>>> http://people.apache.org/~smartini/F9EDAF10.asc , and
>>>> smartini_apache.asc is only a copy of it with a better name.
>>>>
>>>> Please vote to publish this release by Monday , July 03 at 12:00 GMT.
>>>> Note that voting may conclude early if people have the time to look
>>>> earlier (but in any case, minimum 72 hours).
>>>>
>>>> Remember that the Apache Voting Process requires a minimum of 3
>>>> Bindings +1 vote for the release to be successful (see the "Votes on
>>>> Package Release" paragraph).
>>>>
>>>> In your vote, please include the testing you performed to arrive at your
>>>> vote.
>>>>
>>>> [  ] +1 Publish
>>>> [  ] +0
>>>> [  ] -0
>>>> [  ] -1 Don't publish
>>>>
>>>> Thanks,
>>>> Sandro
>>>>
>>>>
>>>
>

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Java Versions, was; [VOTE] Release Pivot 2.0.5

Niclas Hedhman-2
Another tip; rat can be told to skip files that are known to be ok, so
doesn't show up as a failure (not enabled here).

I recall a set of text and csv files that would benefit from that.

On Jul 3, 2017 22:05, "Roger and Beth Whitcomb" <[hidden email]>
wrote:

> Thank you for checking -- that's part of the job ;)
>
> ~Roger
>
>
> On 7/2/17 9:23 PM, Niclas Hedhman wrote:
>
>> Ok, sorry that I haven't followed exactly what is going where and when. It
>> was just in the back of my mind...
>>
>> On Mon, Jul 3, 2017 at 12:02 PM, Roger and Beth Whitcomb <
>> [hidden email]> wrote:
>>
>> The 2.0.x branch still only requires Java 6; this is to maintain backward
>>> compatibility with 2.0.4, since it is only a bug fix release, basically.
>>> For "trunk" though (that will be 2.1, probably), we are now requiring
>>> Java
>>> 8...
>>>
>>> HTH,
>>> ~Roger
>>>
>>>
>>> On 7/2/17 4:58 PM, Niclas Hedhman wrote:
>>>
>>> +1 from me.
>>>>
>>>> But for future reference, doesn't Pivot require Java 7 or Java 8
>>>> already??
>>>> The manifest says 1.6. Small detail IMHO, but I thought I should mention
>>>> it.
>>>>
>>>> =======================================================================
>>>> ==./eclipse/META-INF/MANIFEST.MF
>>>> =======================================================================
>>>> Manifest-Version: 1.0
>>>> Bundle-ManifestVersion: 2
>>>> Bundle-Name: Eclipse Plug-in for Apache Pivot
>>>> Bundle-SymbolicName: org.apache.pivot.eclipse;singleton:=true
>>>> Bundle-Version: 2.0
>>>> Bundle-Vendor: Apache Software Foundation
>>>> Bundle-RequiredExecutionEnvironment: JavaSE-1.6
>>>> Require-Bundle: org.eclipse.core.runtime;bundle-version="3.5.0",
>>>>    org.eclipse.ui;bundle-version="3.5.2",
>>>>    org.eclipse.swt;bundle-version="3.5.2",
>>>>    org.eclipse.jface;bundle-version="3.5.2",
>>>>    org.eclipse.debug.core;bundle-version="3.5.1",
>>>>    org.eclipse.debug.ui;bundle-version="3.5.2",
>>>>    org.eclipse.jdt.core;bundle-version="3.5.2",
>>>>    org.eclipse.jdt.launching;bundle-version="3.5.1",
>>>>    org.eclipse.jdt.debug.ui;bundle-version="3.4.1"
>>>>
>>>>
>>>>
>>>> On Mon, Jun 26, 2017 at 6:00 AM, Sandro Martini <
>>>> [hidden email]
>>>> wrote:
>>>>
>>>> Hi All,
>>>>
>>>>> the Pivot 2.0.5 release candidate has been tagged, packaged, and is
>>>>> ready for a vote.
>>>>> The artifacts, RAT reports, and KEYS file can be found here:
>>>>> http://people.apache.org/~smartini/pivot-2.0.5_release/
>>>>>
>>>>> Note that just for convenience there are even Maven bundles for
>>>>> installing them in a real Maven Repository:
>>>>> http://people.apache.org/~smartini/pivot-2.0.5_maven/
>>>>>
>>>>>
>>>>> The tag from which the release artifacts were generated can be found
>>>>> here:
>>>>> http://svn.apache.org/repos/asf/pivot/tags/2.0.5/
>>>>>
>>>>> In addition, my PGP public code signing key can be found at the MIT
>>>>> key server (http://pgp.mit.edu/), but just for convenience that key is
>>>>> even here:
>>>>> http://people.apache.org/~smartini/F9EDAF10.asc , and
>>>>> smartini_apache.asc is only a copy of it with a better name.
>>>>>
>>>>> Please vote to publish this release by Monday , July 03 at 12:00 GMT.
>>>>> Note that voting may conclude early if people have the time to look
>>>>> earlier (but in any case, minimum 72 hours).
>>>>>
>>>>> Remember that the Apache Voting Process requires a minimum of 3
>>>>> Bindings +1 vote for the release to be successful (see the "Votes on
>>>>> Package Release" paragraph).
>>>>>
>>>>> In your vote, please include the testing you performed to arrive at
>>>>> your
>>>>> vote.
>>>>>
>>>>> [  ] +1 Publish
>>>>> [  ] +0
>>>>> [  ] -0
>>>>> [  ] -1 Don't publish
>>>>>
>>>>> Thanks,
>>>>> Sandro
>>>>>
>>>>>
>>>>>
>>>>
>>
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Java Versions, was; [VOTE] Release Pivot 2.0.5

Sandro Martini
Hi Niclas, thanks for the tip, I'll take a look (maybe with a
dedicated JIRA issue, to not forget :-) ) ...

Bye


2017-07-04 14:44 GMT+02:00 Niclas Hedhman <[hidden email]>:

> Another tip; rat can be told to skip files that are known to be ok, so
> doesn't show up as a failure (not enabled here).
>
> I recall a set of text and csv files that would benefit from that.
>
> On Jul 3, 2017 22:05, "Roger and Beth Whitcomb" <[hidden email]>
> wrote:
>
>> Thank you for checking -- that's part of the job ;)
>>
>> ~Roger
>>
>>
>> On 7/2/17 9:23 PM, Niclas Hedhman wrote:
>>
>>> Ok, sorry that I haven't followed exactly what is going where and when. It
>>> was just in the back of my mind...
>>>
>>> On Mon, Jul 3, 2017 at 12:02 PM, Roger and Beth Whitcomb <
>>> [hidden email]> wrote:
>>>
>>> The 2.0.x branch still only requires Java 6; this is to maintain backward
>>>> compatibility with 2.0.4, since it is only a bug fix release, basically.
>>>> For "trunk" though (that will be 2.1, probably), we are now requiring
>>>> Java
>>>> 8...
>>>>
>>>> HTH,
>>>> ~Roger
>>>>
>>>>
>>>> On 7/2/17 4:58 PM, Niclas Hedhman wrote:
>>>>
>>>> +1 from me.
>>>>>
>>>>> But for future reference, doesn't Pivot require Java 7 or Java 8
>>>>> already??
>>>>> The manifest says 1.6. Small detail IMHO, but I thought I should mention
>>>>> it.
>>>>>
>>>>> =======================================================================
>>>>> ==./eclipse/META-INF/MANIFEST.MF
>>>>> =======================================================================
>>>>> Manifest-Version: 1.0
>>>>> Bundle-ManifestVersion: 2
>>>>> Bundle-Name: Eclipse Plug-in for Apache Pivot
>>>>> Bundle-SymbolicName: org.apache.pivot.eclipse;singleton:=true
>>>>> Bundle-Version: 2.0
>>>>> Bundle-Vendor: Apache Software Foundation
>>>>> Bundle-RequiredExecutionEnvironment: JavaSE-1.6
>>>>> Require-Bundle: org.eclipse.core.runtime;bundle-version="3.5.0",
>>>>>    org.eclipse.ui;bundle-version="3.5.2",
>>>>>    org.eclipse.swt;bundle-version="3.5.2",
>>>>>    org.eclipse.jface;bundle-version="3.5.2",
>>>>>    org.eclipse.debug.core;bundle-version="3.5.1",
>>>>>    org.eclipse.debug.ui;bundle-version="3.5.2",
>>>>>    org.eclipse.jdt.core;bundle-version="3.5.2",
>>>>>    org.eclipse.jdt.launching;bundle-version="3.5.1",
>>>>>    org.eclipse.jdt.debug.ui;bundle-version="3.4.1"
>>>>>
>>>>>
>>>>>
>>>>> On Mon, Jun 26, 2017 at 6:00 AM, Sandro Martini <
>>>>> [hidden email]
>>>>> wrote:
>>>>>
>>>>> Hi All,
>>>>>
>>>>>> the Pivot 2.0.5 release candidate has been tagged, packaged, and is
>>>>>> ready for a vote.
>>>>>> The artifacts, RAT reports, and KEYS file can be found here:
>>>>>> http://people.apache.org/~smartini/pivot-2.0.5_release/
>>>>>>
>>>>>> Note that just for convenience there are even Maven bundles for
>>>>>> installing them in a real Maven Repository:
>>>>>> http://people.apache.org/~smartini/pivot-2.0.5_maven/
>>>>>>
>>>>>>
>>>>>> The tag from which the release artifacts were generated can be found
>>>>>> here:
>>>>>> http://svn.apache.org/repos/asf/pivot/tags/2.0.5/
>>>>>>
>>>>>> In addition, my PGP public code signing key can be found at the MIT
>>>>>> key server (http://pgp.mit.edu/), but just for convenience that key is
>>>>>> even here:
>>>>>> http://people.apache.org/~smartini/F9EDAF10.asc , and
>>>>>> smartini_apache.asc is only a copy of it with a better name.
>>>>>>
>>>>>> Please vote to publish this release by Monday , July 03 at 12:00 GMT.
>>>>>> Note that voting may conclude early if people have the time to look
>>>>>> earlier (but in any case, minimum 72 hours).
>>>>>>
>>>>>> Remember that the Apache Voting Process requires a minimum of 3
>>>>>> Bindings +1 vote for the release to be successful (see the "Votes on
>>>>>> Package Release" paragraph).
>>>>>>
>>>>>> In your vote, please include the testing you performed to arrive at
>>>>>> your
>>>>>> vote.
>>>>>>
>>>>>> [  ] +1 Publish
>>>>>> [  ] +0
>>>>>> [  ] -0
>>>>>> [  ] -1 Don't publish
>>>>>>
>>>>>> Thanks,
>>>>>> Sandro
>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>
>>
Loading...