[jira] [Commented] (PIVOT-895) Update requirements to Java 7

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[jira] [Commented] (PIVOT-895) Update requirements to Java 7

JIRA jira@apache.org

    [ https://issues.apache.org/jira/browse/PIVOT-895?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16053030#comment-16053030 ]

Sandro Martini commented on PIVOT-895:
--------------------------------------

This issue is superseded now by: PIVOT-998, by updating requirements (and code, thanks to the new syntax and language features) to the current release, Java 8

> Update requirements to Java 7
> -----------------------------
>
>                 Key: PIVOT-895
>                 URL: https://issues.apache.org/jira/browse/PIVOT-895
>             Project: Pivot
>          Issue Type: Improvement
>            Reporter: Sandro Martini
>            Assignee: Sandro Martini
>              Labels: build, dependencies, java
>             Fix For: 2.1, 2.1.0
>
>
> Now that Java 6 is going in Out-of-Life (and support without paying for it) it's time to update dependencies and require Java 7 as a minimum version to build and run Pivot Applications.
> Of course maintenance branch 2.0.x will stay with Java 6 as requirements.
> Some related info:
> http://www.oracle.com/technetwork/java/eol-135779.html
> http://www.infoq.com/news/2012/08/ava-6-eol-extended
> And then, verify if disable (not delete for now) existing jobs on Jenkins that builds the trunk with Java 6 ... anyway they could be useful to see if we have some incompatibility with Java 6.
> Then, we can even remove few little tricks due to bugs (not fixed) in Java 6.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)
Loading...